create-new-course function won't save course

Backend functionalities: user management, course management, reports, certificates, etc.
Post Reply
docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

create-new-course function won't save course

Post by docebogal »

Hello,
I am a site admin and have been using docebo for a few years.
I haven't created a new course in a while, and today I logged-in and went to Admin/elearning/elearning/course.
I clicked on new, and the new course template came up, I entered the name of course, description, etc.
When I was done, I clicked on save changes. Instead of saving and exiting the template, the template cleared all fields remained open and did not save.
Just to be sure I went to elearning/elearning/course and there was no new course.
I also went to Edit an existing course - same problem; wouldn't leave course creation template screen after clicking Save Changes.
I am able to Save Changes in other areas. For Example: Main/config/settings

Ideas?
Please help.

User avatar
max
FormaLms Guru
Posts: 2558
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: create-new-course function won't save course

Post by max »

Hello Docebogal and welcome on board!

What you describe is a really strange behaviour. What version of Docebo are you using?
Also: has there been any changes in your server configuration?
The first thing I can think of is server-related: I can imagine that some folders don't have the right settings anymore. You should check with your IT if the folder files/doceboCore exists and is writable by Apache. The correct setting is "777".
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: create-new-course function won't save course

Post by docebogal »

Thanks, I'll check.
I began having the problem under 4.04, so I upgraded hoping it would reset any problems - same problem on 4.05

I'll check on the server side, and see if there is any trouble.
Interestingly, I can create and save a new user?

thanks,

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: create-new-course function won't save course

Post by docebogal »

It seemed to be an IE9 Issue...
IT was able to create a course using Chrome browser

User avatar
max
FormaLms Guru
Posts: 2558
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: create-new-course function won't save course

Post by max »

In this thread there is some more information about how to force the "compatibility view" on IE9, so that Docebo forces it to behave as IE8 (and to work correctly)

viewtopic.php?f=5&t=56&hilit=IE9

unfortunately the thread is in Italian, but if you google-translate it you should have a good understanding of what is being discussed.

basically you have to add a meta tag into the relevant page or - better - in the template

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />

to do that in the template, go to templates/standard/layout and open the lms.php file

then add the meta tag under the "title" row, as in the image that you can see in the thread I linked to.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: create-new-course function won't save course

Post by docebogal »

Perfect. Thank you!

Post Reply