Problem Configuring LDAP

Backend functionalities: user management, course management, reports, certificates, etc.
Post Reply
cherqimohammed
Newbie
Posts: 3
Joined: Wed Dec 23, 2015 10:55 am
Version: forma.lms 1.4.1

Problem Configuring LDAP

Post by cherqimohammed »

Hi everyone,

I'm having a hard time configuring LDAP.
I need some information regarding the field : Username for LDAP users. What should be written here?

Thanks in advance.

User avatar
max
FormaLms Guru
Posts: 2379
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Problem Configuring LDAP

Post by max »

Hi, welcome to this community.

The text string you already find in that configuration field, as well as the server address and the port, are examples of the most common configurations you can have. Then, it's up to you to know if they fit with your case: we cannot know that.
In that specific field, you have to insert a string built like in the provided example.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

cherqimohammed
Newbie
Posts: 3
Joined: Wed Dec 23, 2015 10:55 am
Version: forma.lms 1.4.1

Re: Problem Configuring LDAP

Post by cherqimohammed »

Thank you for your reply.

I mentioned the correct ip adress and port number of our server. In the third field I've inserted this string : $user@domain.com where domain.com represents respectively domain2 and domain1. And unfortunately, It doesn't work.

And one more thing, when I activate the LDAP authentication, I can't log in with the admin user(the one that I created during installation). Is there an additonnal config that I have to make in order to login with the admin user?

User avatar
max
FormaLms Guru
Posts: 2379
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Problem Configuring LDAP

Post by max »

I cannot help you on the first issue, I am not technical enough, but there must be something wrong in the text string you inserted.

For the second issue, it's logical that you can't access...: if you enable LDAP authentication, the admin user you created must exist in the Active Directory.... Either you use LDAP or not, you can't have it both ways.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

cherqimohammed
Newbie
Posts: 3
Joined: Wed Dec 23, 2015 10:55 am
Version: forma.lms 1.4.1

Re: Problem Configuring LDAP

Post by cherqimohammed »

Ok I see. Thanks for your help.

Can anybody help me on this matter? I'm stuck. I tried to debug the app but i couldn't find the authentication class.

Post Reply