SCORM not loaded with error

Backend functionalities: user management, course management, reports, certificates, etc.
Post Reply
stevie
Newbie
Posts: 2
Joined: Fri May 08, 2020 12:00 pm

SCORM not loaded with error

Post by stevie »

Hi
I try to load a scorm file. I tested the file in scormcloud, it was OK, no error
But when I try to load into formalms I have an error message :

Fatal error: Uncaught ArgumentCountError: Too few arguments to function sl_upload(), 2 passed in /homepages/43/d759802513/htdocs/eLearning/appLms/modules/scorm/scorm.php on line 90 and exactly 3 expected in /homepages/43/d759802513/htdocs/eLearning/lib/lib.upload.php:74 Stack trace: #0 /homepages/43/d759802513/htdocs/eLearning/appLms/modules/scorm/scorm.php(90): sl_upload('/tmp/phptXEDbo', '/appLms/scorm/1...') #1 /homepages/43/d759802513/htdocs/eLearning/appLms/modules/scorm/scorm.php(449): insitem() #2 /homepages/43/d759802513/htdocs/eLearning/appLms/class.module/class.scorm.php(24): include('/homepages/43/d...') #3 /homepages/43/d759802513/htdocs/eLearning/appLms/index.php(104): Module_Scorm->loadBody() #4 {main} thrown in /homepages/43/d759802513/htdocs/eLearning/lib/lib.upload.php on line 74

The scorm was made with articulate

Could you help me ?
Thanks

User avatar
max
FormaLms Guru
Posts: 2375
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: SCORM not loaded with error

Post by max »

Hi and welcome on board.

if the scorm is ok it seems that you have issues with uploads in forma. Are you able to upload anything? I mean files, not scorm
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

alfa24
Senior Boarder
Posts: 964
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: SCORM not loaded with error

Post by alfa24 »

I'm Jasmines, the One. If you need, you can contact me.

User avatar
CisterNino
FormaLms User
Posts: 63
Joined: Mon May 06, 2013 2:59 pm

Re: SCORM not loaded with error

Post by CisterNino »

Hi Stevie,
even if alfa24 suggestion fixes your issue, you have to downdrade php version to 7.0.33. This is the correct version for forma.lms 2.3 and 2.4.1. Otherwise you will face with other errors.
Forma.lms 3.0 will support php 7.4.
I'm Livio, the Two. If you need, you can contact the one.

Post Reply