Association Question Type not working

Anything about what happens on the user and teacher side
Post Reply
asals001
Newbie
Posts: 7
Joined: Wed Dec 11, 2013 2:57 pm

Association Question Type not working

Post by asals001 »

Hi Guys

I have created an association type question.

I have set the correct associations and assigned a score to each correct response (See associations.png image attached).

When completing the question as a learner, the LMS is only tracking the first response. For example:
  • If I match all columns correctly - I get 1 point instead of 4.
  • If I get the first column matched correctly and the rest wrong, I get 1 point instead of 0

This is most certainly a bug - is there a patch for this?
Attachments
associations.png

User avatar
max
FormaLms Guru
Posts: 2379
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Association Question Type not working

Post by max »

Hi, yes it's a bug and it has been fixed.
Don't remember if it's in the 2.4.2 or if it will end up in 2.4.3 (upcoming)
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

asals001
Newbie
Posts: 7
Joined: Wed Dec 11, 2013 2:57 pm

Re: Association Question Type not working

Post by asals001 »

Thanks, is there any way we can confirm this?

I'm happy to pay for membership in order to get the latest version - provided it's going to fix my problem.

asals001
Newbie
Posts: 7
Joined: Wed Dec 11, 2013 2:57 pm

Re: Association Question Type not working

Post by asals001 »

Hey guys

Can anyone tell me if this has been fixed in 2.4.2?

Have 100 users lined up for an assessment on Monday.

User avatar
max
FormaLms Guru
Posts: 2379
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Association Question Type not working

Post by max »

Hi,

I checked on our testing LMS, a 2.4.2.
Attachments
Cattura.PNG
Cattura.PNG (7.71 KiB) Viewed 189 times
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

User avatar
max
FormaLms Guru
Posts: 2379
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Association Question Type not working

Post by max »

Just to be clear: the purpose of becoming a member is to support the project in general, not fixing a single issue. I understand you have an urgent need, but in open source you either wait for the next release or you fix yourself. That is a separate issue from being or not being a member.

It's different of course for our direct customers: for them, all the bugfixes and the new functions are immediate, they don't need to wait. They're the ones mainly financing the whole thing.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

asals001
Newbie
Posts: 7
Joined: Wed Dec 11, 2013 2:57 pm

Re: Association Question Type not working

Post by asals001 »

I am aware how open source works.
Your initial response indicated that there may or may not be a fix to the issue in a release - which is hidden behind a paywall. I simply asked for clarification.

Post Reply