Forma 1.3 - Pulsante HelpDesk non funziona

Domande sulle funzionalità di backend: amministrazione utenti e corsi, certificati, iscrizioni, report, ...
davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

Facendo click su HelpDesk rimane il popup di caricamento
Caricamento HelpDesk
Caricamento HelpDesk
e4.jpg (40.03 KiB) Viewed 1431 times
viene richiamato correttamente il modulo come si vede qui sotto ma niente torna indietro, lo script quindi fallisce:
e5.jpg
e5.jpg (33.31 KiB) Viewed 1431 times

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

aprendo /forma/appLms/ajax.server.php?mn=customer_help&plf=lms&op=getdialog

si visualizza il messaggio {"fatal":"Security issue, the request seem invalid ! Try a new login and retry."}

User avatar
alberto
FormaLms Guru
Posts: 990
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by alberto »

Ciao a me funziona, dal messaggio di errore sembrerebbe che ti sia scaduta la sessione... hai provato riloggandoti?
Stai testando un'installazione pulita o un upgrade?
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

installazione pulita, si ho provato a riloggarmi
c'era una qualche tabella di permessi se non ricordo male?

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

l'errore di permessi insufficienti viene generato dall'istruzione

Code: Select all

Boot::init(BOOT_DATETIME);
nel file /appLms/ajax.server.php

qualcuno sa dirmi qualcosa?

User avatar
canelli
FormaLms Guru
Posts: 490
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by canelli »

questo msg di errore:

Code: Select all

{"fatal":"Security issue, the request seem invalid ! Try a new login and retry."}
è relativo al fatto che è stato richiamato direttamente l'url

Code: Select all

http://servername/appLms/ajax.server.php?mn=customer_help&plf=lms&op=getdialog
la pagina si aspetta un POST e non un GET.

devi verificare cosa ti restituisce il server nella finestra della pagina principale:
formalms_hd_risposta.jpg
formalms_hd_risposta.jpg (137.92 KiB) Viewed 1416 times
il risultato del bottone help desk dovrebbe essere questo:
formalms_helpdesk.jpg
formalms_helpdesk.jpg (62.52 KiB) Viewed 1416 times
TI rimane pagina grigia per tutti i tipi di utenti ? anche per gli amminitratori ?
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

l'utente con cui ho fatto le prove è un amministratore

il o.responseText alla riga 62 di /appLms/modules/customer_help/customer_help.js è vuota, quindi è il file php che non restituisce risultati.
e8.jpg
e8.jpg (230.09 KiB) Viewed 1413 times

User avatar
canelli
FormaLms Guru
Posts: 490
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by canelli »

ma nel pannello "NET" di firebug come risultato del post dell'url cosa ti dice ?
quale status ? cosa vedi nel tab "Risposta" ?
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

come detto tab risposta bianco, non ci sono errori
e9.jpg
e9.jpg (32.26 KiB) Viewed 1410 times

User avatar
canelli
FormaLms Guru
Posts: 490
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by canelli »

non riesco a riprodurre il tuo errore.
il contenuto della popup è generato dal file appLms\modules\customer_help\ajax.customer_help.php
controlla che esista nella tua installazione e che sia integro
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

Post Reply