Forma 1.3 - Pulsante HelpDesk non funziona

Domande sulle funzionalità di backend: amministrazione utenti e corsi, certificati, iscrizioni, report, ...
davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

è presente ed integro.

ma le permission come faccio a testarle?? io sono abbastanza certo sia un problema di dati.

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

il file è presente e integro.
io continuo ancora a pensare sia un problema di permission.
apparte che i parametri della richiesta sembrano passati in get (almeno firebug mostra quello)

provando a inserire questo form all'interno della pagina

Code: Select all

<form target="_blank" action="/forma/appLms/ajax.server.php" method="[b]POST[/b]">
  <input type="text" value="customer_help" name="mn">
  <input type="text" value="getdialog" name="op">
  <input type="text" value="lms" name="plf">	
  <input type="submit" name="invia" value="invia">
</form>
la pagina risponde comunque {"fatal":"Security issue, the request seem invalid ! Try a new login and retry."}

Code: Select all

<form target="_blank" action="/forma/appLms/ajax.server.php" method="[b]GET[/b]">
  <input type="text" value="customer_help" name="mn">
  <input type="text" value="getdialog" name="op">
  <input type="text" value="lms" name="plf">	
  <input type="submit" name="invia" value="invia">
</form>
la pagina risponde comunque {"fatal":"Security issue, the request seem invalid ! Try a new login and retry."}

la tua è una nuova installazione o un aggiornamento?

User avatar
canelli
FormaLms Guru
Posts: 490
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by canelli »

ho provato sia su installazioni nuove che aggiornate.
Non c'è nessuna interazione con il database, quindi è indipendente.

Code: Select all

 {"fatal":"Security issue, the request seem invalid ! Try a new login and retry."}
Forma.lms non accetta i dati di un form (POST) che provengano da form costruiti all'esterno.
c'è un controllo che il form sia stato generato dalla stessa applicazione , questo per evitare cross site posting.
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

Scusate ma ci sarà un modo per debuggare questa classe , voi come fate??
Last edited by davide.desimone on Sat Dec 13, 2014 3:29 pm, edited 1 time in total.

User avatar
canelli
FormaLms Guru
Posts: 490
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by canelli »

denigrare ?
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

Debuggare scusa!

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

A nessuno viene in mente niente???

User avatar
canelli
FormaLms Guru
Posts: 490
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by canelli »

hai provato con uno strumento di debug a verificare l'esecuzione della funzione ajax di generazione del popup ?
oppure con il vecchio ma sempre efficace metodo di mettere qualche print (sicuramente la risposta json va in errore, ma con Firebug dovresti riuscire a vedere l'output generato.
il file che genera il contenuto popup è

Code: Select all

appLms\modules\customer_help\ajax.customer_help.php
e la parte interessata è l'opzione getdialog

Code: Select all

switch ($op) {

	case "getdialog": {
                             .......
hai errori PHP ? verifica nel file di log di apache , nel file di log dei php error (abilita se necessario la scrittura degli errori PHP su file)
su quale tipo di server riscontri l'errore ?
che versione di PHP ?
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

davide.desimone
FormaLms User
Posts: 107
Joined: Sun Mar 04, 2012 12:11 pm

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by davide.desimone »

ho abilitato il debug:

<br />
<b>Warning</b>: Unexpected character in input: '\' (ASCII=92) state=1 in <b>/home/siti/sito/sito/htdocs/forma/appLms/modules/customer_help/ajax.customer_help.php</b> on line <b>139</b><br />
<br />
<b>Parse error</b>: syntax error, unexpected T_FUNCTION in <b>/home/siti/sito/sito/htdocs/forma/appLms/modules/customer_help/ajax.customer_help.php</b> on line <b>190</b><br />

modificando

Code: Select all

 throw new \InvalidArgumentException('parse_user_agent requires a user agent');
in

Code: Select all

 throw new InvalidArgumentException('parse_user_agent requires a user agent');
mi rimane <br />
<b>Parse error</b>: syntax error, unexpected T_FUNCTION in <b>/home/siti/sito/sito/htdocs/forma/appLms/modules/customer_help/ajax.customer_help.php</b> on line <b>190</b><br />

alla riga 190 del file ho l'intestazione di questa funzione:

Code: Select all

        $find = function ( $search, &$key ) use ( $result ) {
                    $xkey = array_search(strtolower($search), array_map('strtolower', $result['browser']));
                    if ($xkey !== false) {
                        $key = $xkey;

                        return true;
                    }

                    return false;
                };
non riesco a capire cosa non vada.

ho la PHP Version 5.2.6-1+lenny8

Forma 1.3

User avatar
alberto
FormaLms Guru
Posts: 990
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Forma 1.3 - Pulsante HelpDesk non funziona

Post by alberto »

Oddio, ancora php 5.2? Prova ad aggiornare alla 5.3 o 5.4
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

Post Reply