The Elearning Community • Propedeuticità non funzionante in percorso formativo
Page 1 of 1

Propedeuticità non funzionante in percorso formativo

Posted: Wed May 16, 2018 8:05 am
by ludan
Buongiorno,
ho il problema seguente: ho definito 2 corsi in un percorso formativo e gestito la rispettiva propedeuticità per la quale è necessario completare il primo per accedere al secondo; il sistema ha messo effettivamente il lucchetto al corso che deve essere fatto per secondo, ma in realtà lo stesso risulta comunque cliccabile ed accessibile.
Ho provato a generare un nuovo utente ma non funziona.
Ho provato tutte le le possibili interazioni con la piattaforma con il mio utente amministratore ma non ho trovato la soluzione.
Sapete suggerirmi dove sbaglio o come risolvere il problema per evitare di generare confusione per gli utenti che vedono sia i corsi singoli che il percorso.

Grazie, buona giornata.
Luigi

Re: Propedeuticità non funzionante in percorso formativo

Posted: Wed May 16, 2018 8:13 am
by max
Buongiorno Luigi,
su Forma 1.4 il problema è che se sei iscritto a un percorso (e la TAB "percorsi" è attiva), da quella tab la propedeuticità funziona correttamente. Tuttavia, l'utente vede gli stessi corsi anche nella tab elearning e in quel caso può "fregare" i prerequisiti.
Su Forma 1.4 l'unica soluzione che vedo è spegnere il tab dei corsi e lasciare solo quello dei percorsi.
Su Forma 2 abbiamo corretto questo comportamento: se sei iscritto a un percorso, i relativi corsi li vedi solo da lì e non dal tab elearning.

Re: Propedeuticità non funzionante in percorso formativo

Posted: Wed May 16, 2018 9:17 am
by ludan
grazie Max

Re: Propedeuticità non funzionante in percorso formativo

Posted: Thu May 17, 2018 9:16 am
by ludan
Buongiorno Massimiliano,
ho verificato con attenzione quanto mi dici ed ho compreso la possibilità di una modifica destinata a "spegnere" il tab corsi; il problema essenziale è tuttavia che nella tab "percorsi formativi" (piattaforma 1.4.1) il corso per il quale è prevista una propedeuticità, sebbene rechi il lucchetto, RIMANE CLICCABILE NEL TESTO (vd. screenshot allegato) e dunque accessibile ed utilizzabile, ignorando la propedeuticità di fatto.
Per cui anche se provvedo alla modifica di "spegnimento" dei corsi, non risolvo il problema.
Sai darmi un suggerimento o dirmi se sbaglio qualcosa?
Grazie infinite
L.

Re: Propedeuticità non funzionante in percorso formativo

Posted: Thu May 17, 2018 4:56 pm
by alberto
Ciao, sei loggato come superadmin/amin del corso o come studente?
Non ricordo esattamente sui percorsi, ma nell'elenco corsi ci sono sicuramente delle eccezioni che consentono agli amministratori di accedere anche a corso chiuso, mentre gli studenti non entrano. Nel caso fai un test anche con un account da utente/studente e dicci se il comportamento è corretto

Re: Propedeuticità non funzionante in percorso formativo

Posted: Thu May 17, 2018 5:53 pm
by ludan
Ciao Alberto,
il problema che riferisco si verifica con un logon come utente semplice.
Grazie L.

Re: Propedeuticità non funzionante in percorso formativo

Posted: Thu May 17, 2018 7:00 pm
by alberto
Non riesco a testare al volo su vecchie versioni, ma ho verificato su una 2.0 e il problema non si presenta, se c'era un bug è stato risolto con la nuova release

Re: Propedeuticità non funzionante in percorso formativo

Posted: Mon Dec 03, 2018 4:35 pm
by ludan
Buonasera Alberto, a distanza di 6 mesi torno a richiedere supporto per il medesimo problema della propedeuticità ,che a me fallisce anche su Forma 2.0.
Provo a riassumere sebbene difficilmente pensi di aver sbagliato poichè il processo è molto semplice e chiaro.

1. creo due corsi A e B
2. creo un percorso formativo importando i corsi A e B
3. entro nel percorso formativo e clicco su icona di modifica percorso
4. in corrispondenza del lucchetto del corso B, metto la spunta su prerequisito al corso A.
5. associo un utente di prova al percorso, salvo tutto, mi disconnetto come amministratore e mi loggo come utente di prova.

A questo punto se come utente entro all'interno del percorso vedo correttamente il lucchetto sul corso B CHE TUTTAVIA RIMANE CLICCABILE e pienamente fruibile a prescindere dal completamento del corso A.

Vi chiedo la gentilezza di un riscontro poichè per noi questo aspetto risulta ASSOLUTAMENTE DETERMINANTE per l'uso della piattaforma.
Grazie infinite
Buona giornata
Luigi

Re: Propedeuticità non funzionante in percorso formativo

Posted: Fri Jan 18, 2019 6:34 pm
by ludan
Buongiorno, nonostante abbia scritto più volte ed a più destinatari, non riesco a ricevere alcun riscontro o supporto riguardo la problematica segnalata.
Ho seguito tutte le indicazioni ricevute, ivi incluse prove su aggiornamenti di ultima versione rilasciata (2.1) ma il bug continua ad essere presente.
Purtroppo per noi la propedeuticità rappresenta un elemento essenziale ed in verità non comprendo come nessun altro ne abbia fatto cenno, stante che il "percorso formativo" credo rappresenti una modalità ricorrente.
Come già segnalato ho un account pronto per farvi verificare direttamente la criticità, ma chiedo la gentilezza di una risposta, poiché in mancanza saremmo purtroppo costretti ad abbandonare la piattaforma, in cerca di una soluzione alternativa.
Resto in attesa di un vostro cortese riscontro
Cordiali saluti
LD

Re: Propedeuticità non funzionante in percorso formativo

Posted: Fri Jan 18, 2019 8:39 pm
by alfa24
Amico mi sono messo a disposizione, ti ho scritto 2 pm con la disponibilità a usare teamviewer che hai letto e a cui non hai dato riscontro. Qual è il problema? Scrivimi il tuo numero di telefono in privato ti chiamerò senz'altro.

This site uses cookies.

Some of the cookies we use are essential for parts of the site to operate and have already been set. We also use Google Analytics scripts, which all use cookies.
You may delete or block all cookies from this site in your browser options.