campi supplementari

Domande sulle funzionalità di backend: amministrazione utenti e corsi, certificati, iscrizioni, report, ...
danilo
FormaLms User
Posts: 118
Joined: Wed Feb 04, 2015 5:33 pm

campi supplementari

Post by danilo »

Ciao, ho effettuato l'aggiornamento alla 2.4.2 e sto riscontrando un problema con i campi supplementari assegnati al nodo dell'organigramma.
In pratica, creando un nuovo utente, ci sono solo i campi di default, non quelli supplementari.
Accedendo con il nuovo account, non vengono nemmeno proposti all'utente per la compilazione (come è sempre stato).
Visualizzando il profilo, i campi ci sono, ma non sono compilati, ovviamente.
Avete idea di cosa può essere successo?
Grazie

PS
in aggiunta a questo, non vengono inviate le email di notifica del nuovo utente :(

danilo
FormaLms User
Posts: 118
Joined: Wed Feb 04, 2015 5:33 pm

Re: campi supplementari

Post by danilo »

visto che siamo al 20 agosto e le mie vacanze sono imminenti, sono tornato alla 2.4.1 (e funziona). Spero di poter passare alla 2.4.2 a settembre (in particolare per la risoluzione del bug sul registro valutazioni)

User avatar
max
FormaLms Guru
Posts: 2407
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: campi supplementari

Post by max »

Ciao Danilo,

ho provato sia con campo addizionale assegnato alla root che a un nodo specifico e tutto funziona correttamente, sia in creazione utente che al primo accesso dell'utente stesso che viene forzato a compilare il campo mancante.

Anche l'invio della notifica funziona come deve.

Testato su una 2.4.2. aggiornata da 2.4.1.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

danilo
FormaLms User
Posts: 118
Joined: Wed Feb 04, 2015 5:33 pm

Re: campi supplementari

Post by danilo »

Ciao Max,
le schermate che allego, mostrano due procedure per la creazione di un nuovo utente.
Si tratta di due installazioni di Forma su domini diversi, che puntano allo stesso DB.
con la 2.4.1 ho tutti i campi, compresi i supplementari, mentre, con la 2.4.2 ho solo campi di default. :shock:
Come sempre una spiegazione ci sarà, ma non idea di quale possa essere...
Attachments
Nuovo utente 2.4.1.PNG
Nuovo utente 2.4.2.PNG

alfa24
Senior Boarder
Posts: 1012
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: campi supplementari

Post by alfa24 »

Se assegni i campi ad un sottonodo della root, e tenti di creare un utente in quel sottonodo, si vedono?
I'm Jasmines, the One. If you need, you can contact me.

danilo
FormaLms User
Posts: 118
Joined: Wed Feb 04, 2015 5:33 pm

Re: campi supplementari

Post by danilo »

Ciao jasmines, si i campi supplementari dei sottonodi si vedono.

alfa24
Senior Boarder
Posts: 1012
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: campi supplementari

Post by alfa24 »

Bug su root, allora.
I'm Jasmines, the One. If you need, you can contact me.

danilo
FormaLms User
Posts: 118
Joined: Wed Feb 04, 2015 5:33 pm

Re: campi supplementari

Post by danilo »

Strano che nessuno lo abbia segnalato prima. Come può essere risolto?

alfa24
Senior Boarder
Posts: 1012
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: campi supplementari

Post by alfa24 »

Non sono un associato e non ho a disposizione una 2.4.2 per testare, mi spiace.
I'm Jasmines, the One. If you need, you can contact me.

danilo
FormaLms User
Posts: 118
Joined: Wed Feb 04, 2015 5:33 pm

Re: campi supplementari

Post by danilo »

OK, grazie cmq

Post Reply