[Risolto] Problema con certificati

Domande sulle funzionalità di backend: amministrazione utenti e corsi, certificati, iscrizioni, report, ...
Post Reply
marcello
FormaLms User
Posts: 51
Joined: Tue Apr 10, 2012 9:41 am

[Risolto] Problema con certificati

Post by marcello »

Sono ancora qui a chiedere aiuto ...
Non so se sia un bug, ché forse sarebbe già venuto fuori.
Quello che mi succede è che da amministratore riesco a generare i certificati e a scaricarli perfettamente formattati.
Gli utenti, invece, scaricano un certificato vuoto (cioè un .pdf con una pagina bianca), nel caso questo sia già stato generato dall'amministratore.
Poi non ho capito bene se l'utente può generare da sé il certificato: qualora non l'abbia già generato l'amministratore, infatti, dalla pagina I miei certificati l'utente, cliccando su Nuovo certificato, ottiene dapprima un file denominato "pdf": dopo, provando a scaricarlo (cliccando su Scarica una copia del certificato) un file .pdf il cui nome è un numero: in entrambi i casi, però, il file è vuoto (cioè una pagina bianca).
Ho letto altri post sui certificati, ma non mi sembra riportassero questi strani problemi.
Spero di essere riuscito chiaro (forse ho le idee un po' confuse sui certificati).
Grazie in anticipo.
Last edited by marcello on Fri Oct 04, 2013 2:34 pm, edited 1 time in total.

User avatar
max
FormaLms Guru
Posts: 2349
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Problema con certificati

Post by max »

Ciao Marcello,
in effetti la situazione è strana. Gli step che fai sono tutti giusti, l'utente può scariscarselo da solo e non fa differenza se è generato da lui stesso o dall'amministratore.
Quello che mi viene da pensare è che ci sia qualcosa che va storto durante la generazione del certificato, cioè o c'è un qualche strano problema sul db oppure, più semplicemente, qualcosa che non va nel certificato stesso. Il nome (magari ci sono caratteri accentati o apostrofi) o il contenuto (magari c'è dell'html "sporco"). My 2 cents

Puoi dirci qualcosa di più?
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

marcello
FormaLms User
Posts: 51
Joined: Tue Apr 10, 2012 9:41 am

Re: Problema con certificati

Post by marcello »

Ciao Max e grazie per la risposta.
Posso solo dirti che la cosa strana è che l'amministratore genera e scarica un certificato perfetto: immagine di sfondo, formattazione caratteri, ecc.
Gli utenti, invece, solo un pdf bianco.
Se funziona per l'amministratore, dovrebbe funzionare anche per gli utenti, no?

User avatar
alberto
FormaLms Guru
Posts: 990
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Problema con certificati

Post by alberto »

Versione di docebo? L'immagine di sfondo è un jpg? (tempo fa abbiamo avuto problemi con i png)
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

marcello
FormaLms User
Posts: 51
Joined: Tue Apr 10, 2012 9:41 am

Re: Problema con certificati

Post by marcello »

Ciao Alberto. Grazie anche a te.
Versione 4.0.5. L'immagine di sfondo è un jpg.
Tempo fa avevo apportato questa patch viewtopic.php?f=13&t=48.
Poi se non ricordo male, constatato che non funzionava bene, l'ho rimossa. Forse ho pasticciato un po'. Da allora non avevo più utilizzato la funzione certificati.
Sto cercando di ripristinare i file originali: spero di riuscire a risolvere così.
Vi faccio sapere ...

marcello
FormaLms User
Posts: 51
Joined: Tue Apr 10, 2012 9:41 am

Re: Problema con certificati

Post by marcello »

Ho ripristinato i file originali: \doceboLms\modules\mycertificate\mycertificate.php e \doceboLms\lib\lib.certificate.php
Ora però nella pagina "I miei certificati" degli utenti non compaiono i certificati conseguiti, ma un desolante "Nessun contenuto disponibile" ...
L'amministratore, invece, può generarli e scaricarli.
Purtroppo il cliente vuole che siano proprio i singoli utenti a scaricarli.
Non so come uscirne ...

User avatar
max
FormaLms Guru
Posts: 2349
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Problema con certificati

Post by max »

Mmmm... però se l'amministratore può generarli, dovrebbero comparire anche agli utenti.
Provato a svuotare la cache quando accedi come utente? Magari è semplicemente questione di refreshare la pagina.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

marcello
FormaLms User
Posts: 51
Joined: Tue Apr 10, 2012 9:41 am

Re: Problema con certificati

Post by marcello »

Pare che abbia risolto: è bastato riassegnare i certificati ai corsi per vederli riapparire anche agli utenti.
Spero che sia davvero tutto a posto, ora.
Grazie a Max e Alberto per l'attenzione.

User avatar
max
FormaLms Guru
Posts: 2349
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: [Risolto] Problema con certificati

Post by max »

Ottimo, meglio così!
Grazie a te, Marcello, di aver aggiornato il 3d
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

Post Reply